トップへ
<---   取り出しトピック   --->
 
. KbMedia Player Version 3.09.2021.0418(正式版) Kobarin 04/18日21:52#r294選択
. XP サポート打ち切り Kobarin 04/18日22:06#r295
. Microsoft Edge でダウンロード出来ない Kobarin 04/26月23:07#r301
. ダウンロード出来るようになりました Kobarin 04/29木13:11#r307
 

上の選択記事
. KbMedia Player Version 3.09.2021.0418(正式版)
     Kobarin ホームページ 2021/04/18日21:52 #r294
編集&削除  
http://kobarin.sakura.ne.jp/kbmedia/kbmed309.exe (7-zip の自己解凍書庫)

窓の杜: http://forest.watch.impress.co.jp/library/software/kbmediaply/
(2021/04/18 現在、まだ v3.08 です)
vector: https://www.vector.co.jp/soft/winnt/art/se515017.html
(2021/04/18 現在、まだ v3.08 です)

起動時にエラーメッセージが表示されてプラグインが認識されない場合は
Microsoft Visual C++ 2019 再頒布可能パッケージのインストールが必要です。

https://visualstudio.microsoft.com/ja/downloads/#other-ja-family
x64 版ランタイムファイル直リンク https://aka.ms/vs/16/release/VC_redist.x64.exe
x86 版ランタイムファイル直リンク https://aka.ms/vs/16/release/VC_redist.x86.exe

x64版を使用するためには x64 版だけでなく、x86 版のランタイムも必要です。


v3.08 からの変更点

・サイト移転に伴い、添付ドキュメント等の URL を修正
・本体の開発環境を C++ Builder 10.4.2 (v27.0.40680.4203) に更新
・各種プラグイン/DLL の開発環境を VS2019 16.9.4 に更新
・動画再生時に演奏停止したら動画ウィンドウを閉じるようにした
・kbswf.kpi 配布終了、SWF を再生出来なくなった
 ・Adobe Flash Player サポート終了に伴い、動作しなくなったため
・kbflac.kpi に関する以下の修正
 ・libFLAC を 1.3.3(2019/08/04) に更新
・kbmac.kpi に関する以下の修正
 ・Monkey's Audio SDK 6.14(2021/03/18) に更新
・kbmod.kpi に関する以下の修正
 ・libopenmpt を 0.5.8(2021/04/11) に更新
・kbmpg123.kpi に関する以下の修正
 ・libmpg123 を 1.26.5(2021/03/22) に更新
・kbopus.kpi に関する以下の修正
 ・opusfile を 0.12(2020/06/27) に更新
・kbpxtone.kpi に関する以下の修正
 ・libvorbis を 1.3.7(2020/07/04) に更新
・kbvorbis.kpi に関する以下の修正
 ・libvorbis を 1.3.7(2020/07/04) に更新
・kbwv.kpi に関する以下の修正
 ・libwavpack を 5.4.0(2021/01/10) に更新
・kbsnesapu.kpi に関する以下の修正
 ・snesapu.dll を 2.18.3.7258(2021/03/14) に更新
・kbpsf2.kpi に関する以下の修正
 ・boost ライブラリを 1.75.0.0 に更新
・kbpmd.kpi に関する以下の修正
 ・PMDWin.dll を v0.39(2020/08/16) に更新(VS2019 でビルド)
・kbmsxplug.kpi に関する以下の修正
 ・emu2413 を v1.5.6(2021/02/28) に更新
 ・emu8950 を v1.0.1(2020/02/12) に更新
 ・libkss を 2021/02/05 のものに更新
 ・MSXplug(in_msx) v1.8.0(2020/02/12) を組み込み
・kbs98.kpi に関する以下の修正
 ・emu2413 を v1.5.6(2021/02/28) に更新
 ・VGM(*.vgm/*.vgz) の有効化/無効化を設定出来るようにした
  ・他の VGM 対応プラグインを使用したい場合に無効化する
・kbemidi.kpi に関する以下の修正
 ・emu2413 を v1.5.6(2021/02/28) に更新
・kbunarc.kpi に関する以下の修正
 ・unrarsrc を 6.0.5(2021/04/07) に更新

v3.08beta から 64bit 版のプラグインが vcruntime140_1.dll に依存するようになって
いたようで、v3.07 公開当時やそれ以前にランタイムをインストールした場合だと
バージョンが古くてプラグインをロード出来ない可能性があります。

ランタイムを入れてる筈なのに起動時にダイアログが表示される場合は
再度ランタイムをダウンロード&インストールし直して下さい。

上へ






RAIBPL1.23-wakatiai.halfmoon.jp 2021/11/28日11:01